Unbalanced 306 radiator fan

Discussion in 'Peugeot 306' started by Adrian, Apr 18, 2004.

  1. Adrian

    Adrian Guest

    Last year, the high speed radiator fan on my 306 ran noisily for a
    few months then broke down completely : the impeller fell off.

    It appears that the shaft bent slightly so that the fan blades were
    hitting the cowling, and eventually the unbalanced fan cracked
    the shaft (half of the shaft was still in the impeller).

    After only 6 months, I've started getting a lot of noise from
    the fan - I think it's happened again. I shall have a good
    moan at the garage but I'm amazed that it would go so quickly.
    Is this a common problem, or could they have screwed up
    the repair in some way ?

    -adrian
     
    Adrian, Apr 18, 2004
    #1
    1. Advertisements

  2. Adrian

    Bob Minchin Guest

    Maybe they only fitted a new fan not a new motor as well?

    Can you see the date code on the motor. If you have two fans then the codes
    should be radically different if one has been changed.

    Bob
     
    Bob Minchin, Apr 18, 2004
    #2
    1. Advertisements

  3. Adrian

    Adrian Guest

    No, they must have fitted a new motor - the shaft was broken right off.
    They might have re-fitted the old impeller though, and if it was a bit
    unbalanced it might have bent the new shaft, too ..
     
    Adrian, Apr 20, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.