turn off AC and blower

Discussion in 'Peugeot 406' started by Aravinda, Aug 30, 2015.

  1. Aravinda

    Aravinda

    Joined:
    Aug 30, 2015
    Messages:
    3
    Likes Received:
    1
    Hi,
    I have peugeot 406 D9, sometimes while i driving a car blower and A/C both getting off, after few minutes its turn on back, this is happening several times per day. i noted most of the times this is happening when im in traffic. i changed AC dual relay but still have same issue. Any Ideas??
     
    Aravinda, Aug 30, 2015
    #1
    Hon Segun Abioye likes this.
    1. Advertisements

  2. Aravinda

    kuda

    Joined:
    Sep 25, 2015
    Messages:
    52
    Likes Received:
    3
    hi!
    there should be a loose connector . please check your wiring or also the brushes inside your blow if there are worn it does that.
     
    kuda, Sep 25, 2015
    #2
    Hon Segun Abioye likes this.
    1. Advertisements

  3. Aravinda

    Aravinda

    Joined:
    Aug 30, 2015
    Messages:
    3
    Likes Received:
    1
    hi ,
    thanks for reply, i changed blower module and now blower working fine, but ac not working, i think issue is in BSI unit. my electrition said BSI is very expensive and he can do this without changing BSI it means he is going to add relay to BSI is it ok?
     
    Aravinda, Sep 28, 2015
    #3
  4. Aravinda

    kuda

    Joined:
    Sep 25, 2015
    Messages:
    52
    Likes Received:
    3
    no. dont put relay as yet. the air con works with safety sensors. if the gas in the air con system is low. the air con pump does not respond. confirm the air con pump is engaginging at the engine first. its a clicking sound that comes from the engine if you push the air con button. if it is not engaging, then can the refridgiration guys check your air con system for you the it has enough gas an oil in the system
     
    kuda, Oct 8, 2015
    #4
  5. Aravinda

    kuda

    Joined:
    Sep 25, 2015
    Messages:
    52
    Likes Received:
    3
    the bsi is the last issue here.
     
    kuda, Oct 8, 2015
    #5
  6. Aravinda

    Aravinda

    Joined:
    Aug 30, 2015
    Messages:
    3
    Likes Received:
    1
    thanks for respond,

    finaly found the issue, first issue is in the heat sensor, i changed it, and some eletric short in the compresser, after fixing both issues A/C became a working fine. Thanks for responce guys
     
    Aravinda, Oct 9, 2015
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.