engine power loss

Discussion in 'General Motoring' started by SIPJ, Oct 4, 2004.

  1. SIPJ

    SIPJ Guest

    When driving along the engine will quite regulary loose all
    acceleration but not stall. It will then come back withing a couple
    of seconds. It you are driving on the motorway, this can be very
    annoying when overtaking! Somtimes when you pull up to traffic light
    or a roundabout, the engine will completly stall.

    When this is happening you can dip the clutch, hold your foot on the
    accelerator in the same position and watch the revs rising and falling
    of their own accord.
     
    SIPJ, Oct 4, 2004
    #1
    1. Advertisements

  2. Check that the engine management connectors are securely connected. I had a
    similar problem, after a recent pug service. Called out the AA he took the
    engine cover off and pushed the connectors hard home and problem solved.

    Unfortunately this may only be one of many resolutions, but not the one for
    you. But worth a check.
     
    John Hollinshead, Oct 5, 2004
    #2
    1. Advertisements

  3. SIPJ

    SIPJ Guest

    I have sorted it. It was the MAP sensor, although it cost £65 from
    Peugeot it was well worth it.
     
    SIPJ, Oct 17, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.