engine management light & damp starting

Discussion in 'General Motoring' started by ditechspain, Sep 3, 2006.

  1. ditechspain

    ditechspain Guest

    306 1.6 petrol. For some years this car has had a tendency to display
    the engine management light when the dealer can find no fault. this
    has gradually developed into an apparently damp related problem in that
    if left out in damp weather the light displays and the engine does not
    run on all cylinders. if then left under cover a bit it seems to dry
    out and run normally.

    my diagnostic skills stopped developing when my Hillman Imp went off
    the road and fuel injection and catalyst related ignition is a cold
    book.

    I would have suspected an condensation/insulation related fault in the
    plug/coil leads when I used to do my own maintenance.

    has anyone anyother constructive suggestions before i start replacing
    them? needless to say, having been totally gutless in a 2 mile run
    this morning, it is now running perfectly, although the light is
    still on.

    Thanks
     
    ditechspain, Sep 3, 2006
    #1
    1. Advertisements

  2. ditechspain

    Chris Guest

    Yes spray all the electrics with WD40 that will keep all the damp out.
    you can use it on .H,T. Leads.and coils. it is very safe and very good
    ...from chris Addlestone Surrey
     
    Chris, Sep 3, 2006
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.