Climate control display disappeared from infotainment display on 2009 model 407SW

Discussion in 'Peugeot 407' started by Phil Humphreys, Jun 7, 2018.

  1. Phil Humphreys

    Phil Humphreys

    Joined:
    Jun 7, 2018
    Messages:
    1
    Likes Received:
    0
    Hi, can anyone help, one morning in January I went to car as normal, switched on and display panel refused to light up, I don't know how but I managed to get most things back except climate control display ( air con etc still works but I cannot see what the settings are) and front parking sensors no longer work. I have had it to my local auto electricians , and they have carried out the battery off reload, but that made no difference, and I have tried reloading sat nav discs, which works perfectly, but still no climate display or front parking sensors. Have asked a Peugeot technician who has apparently never come across this fault before. Has anyone got any answers.
     
    Phil Humphreys, Jun 7, 2018
    #1
    1. Advertisements

  2. Phil Humphreys

    fengen

    Joined:
    Nov 13, 2018
    Messages:
    2
    Likes Received:
    0
    Hi.
    Do you have access to a computer with Diagbox or have you gotten a dealer to run a global test and check if some of the settings for the display has been changed?
    There might not be a fault, per say, but something can be for some reason changed.
    What headunit do you have in your car?
     
    fengen, Nov 15, 2018
    #2
    1. Advertisements

  3. Phil Humphreys

    winmick

    Joined:
    Feb 21, 2014
    Messages:
    1
    Likes Received:
    0
    Hi Phil I have same problem for quite awhile now. Did you get your problem fixed. If you did I would love to know how Thanks Michael
     
    winmick, May 20, 2019
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.